nodejs, express, pug, nodemon, net-ping installation

# required to start with nodejs (LTS Version: 8.9.3 (includes npm 5.5.1))
# get and install the latest node LTS (12/2017) from https://nodejs.org/en/download/

https://nodejs.org/dist/v8.9.3/node-v8.9.3-x86.msi
https://nodejs.org/dist/v8.9.3/node-v8.9.3-x64.msi

# check node and npm versions with
node -v (results in v8.9.3)
npm -v (results in v5.5.1)

# install globally (administrator privileges required)

npm i -g --production windows-build-tools --no-optional
npm i express pug net-ping --no-optional

# install dependencies
npm i node-gyp --no-optional
npm i express pug net-ping --no-optional
npm i --no-optional

aniston has written 44 articles